Az Excel alapfüggvények közé azokat soroljuk, amiket a leggyakrabban használunk, és szinte mindennek az alapja. Ezek használatával, egymásba ágyazásával ismerkedhetsz meg ebben a posztban.

Mit nevezünk alapfüggvényeknek az Excelben? Leginkább azokat az egyszerűbb függvényeket, melyek könnyen és gyakran használhatók, egyzserű műveleteket tudunk velük végezni. Tipikusan ilyenek az összeadás, darab számolása, átlagszámítás. Nézzük most ezeket példákkal!

Online Excel tanfolyam

Excel alapfüggvények: SZUM, ÁTLAG, MIN, MAX

SZUM függvény (angolul SUM függvény)

A SZUM függvényről bővebben olvashatsz az  Excel SZUM függvény – leírással, példákkal bejegyzésünkben.

ÁTLAG függvény (angolul AVERAGE függvény)

A megadott számok, cellák számtani átlagát adja vissza eredményül.

MIN függvény (angolul MIN függvény)

A MIN függvény a megadott számok közül a legkisebbet adja vissza.

MAX függvény (angolul MAX függvény)

A MAX függvény a megadott számok közül a legnagyobbat adja vissza.

Excel alapfüggvények: DARAB, DARAB2, DARABTELI

DARAB függvény (angolul COUNT függvény)

Megszámolja, hogy hány olyan cella van, ami számot tartalmaz.

A függvényről bővebben olvashatsz az Excel DARAB függvény magyarázat és példák bejegyzésünkben.

DARAB2 függvény (angolul COUNTA függvény)

Megszámolja, hogy hány olyan cella van, ami bármilyen adatot tartalmaz.

A függvényről bővebben olvashatsz az  Excel DARAB2 függvény magyarázata példákkal bejegyzésünkben.

DARABTELI függvény (angolul COUNTIF függvény)

Megszámolja azokat a nem üres cellákat, amik eleget tesznek a megadott feltételnek.

A függvényről bővebben olvashatsz az Excel DARABTELI függvény példákkal bejegyzésünkben.

Excel alapfüggvények: ÉS, VAGY, HA

ÉS függvény (angolul AND függvény)

Az összes megadott feltétel teljesülése esetén lesz az eredménye IGAZ. Egyébként HAMIS.

A függvényről bővebben olvashatsz Excel ÉS függvény – leírással, példákkal bejegyzésünkben.

VAGY függvény (angolul OR függvény)

Ha legalább egy feltétel igaz, a függvény eredménye IGAZ, egyébként HAMIS.

A függvényről bővebben olvashatsz Excel VAGY függvény – leírással, példákkal bejegyzésünkben.

HA függvény (angolul IF függvény)

Gyakran használt függvény, már mondhatnánk alapfüggvénynek is, bár összetettebb, mint az előzőek. Ellenőrzi, hogy a megadott vizsgálat teljesül-e. Ha igen, akkor az IGAZ esetén megadott értéket, számolást adja vissza, ha HAMIS, akkor a HAMIS esetén megadott értéket, számolást adja eredményül.

A HA függvényről bővebben olvashatsz az Excel HA függvény – leírással, példákkal bejegyzésünkben.

Excel alapfüggvények feladat

A leírásban használt fájlt innen tudod letölteni: Excel alapfüggvények feladat

A táblázatban a versenyen résztvevő csapatokat látod, a települést, ahonnan a csapat nevezett, és a fordulókban elért pontszámot. A vonal (-) jel jelentése: nem vett részt a csapat a fordulóban.

Haladj sorban a feladatokon!

A feladatod, hogy választ adj a következő kérdésekre. Számold ki a függvények segítségével őket:

  • Számold ki az összpontszámot! Csak akkor add össze a fordulók pontjait, ha mindhárom fordulóban részt vettek. Különben nulla jelenjen meg a cellában. (F oszlop)
  • Hány város tartozik Győrhöz? (minden olyan település, amiben szerepel a győr szó) (D15 cellába)
  • Hány csapat nem vett részt a 3. fordulóban? (D16 cellába)
  • Hány átlag feletti összpontszámmal rendelkező csapat van (D17 cellába)
  • Add meg a csapatok Eredményének érvényességét! Az eredmény akkor érvényes, ha az összepontszám nem nulla. (G oszlop)
  • Számold ki, melyik csapat, hány ponttal maradt le az első helyezett csapattól. (H oszlop)
Excel alapfüggvények feladat

Excel alapfüggvények feladat – SZUM, ÁTLAG, ÉS, VAGY

  1. Tehát először az összpontszámot kell kiszámolni csapatonként. Ezt SZUM függvénnyel lehet megadni. Viszont, mivel nem egyszerűen össze kell adni, több függvény is szükséges lesz. Akkor kell összeadni, HA mindhárom fordulóban részt vettek, KÜLÖNBEN nulla jelenjen meg a cellában.

Tehát kell a HA függvény belsejébe egy SZUM függvény, és mivel 3 fordulót vizsgálunk VAGY függvény is.

Ha a három forduló eredménye közül bármelyik – jel akkor, nem kell összegzést végezni.

Az F6 cellába dolgozunk, nézzük a H függvény kitöltését lépésenként.

HA függvény:

  • Logikai vizsgálat: VAGY(C6=”-“;D6=”-“;E6=”-“)
  • IGAZ ág: 0
  • HAMIS ág: SZUM(C6:E6))

A megoldás cellában írva így fest. =HA(VAGY(C6=”-“;D6=”-“;E6=”-“);0;SZUM(C6:E6))

Excel alapfüggvények feladat – SZUM, ÁTLAG, ÉS, VAGY

A VAGY függvény felcserélhető ÉS függvényre is, ekkor a HA függvény IGAZ és HAMIS ágát fel kell cserélni, valamint a logikai feltételek ellentétre változnak (= →<>)

=HA(ÉS (C6<>”-“;D6<>”-“;E6<>”-“);SZUM(C6:E6);0)

Az eredmény ennél a csapatnál: 30

Ahhoz, hogy minden csapat eredményét lásd, másold le a függvényt.

Excel alapfüggvények feladat – DARABTELI függvény

2. Most jön a győri városok száma. Ehhez DARABTELI függvényt kell használnod, és a * helyettesítő karaktert. A győr szó előtt és után bármilyen karakterek állhatnak.

Cellán belül így néz ki: =DARABTELI(B6:B13;”*győr*”)

Excel alapfüggvények feladat – DARABTELI függvény

Az eredmény: 4

Excel alapfüggvények feladat – DARAB, DARAB2 függvények

3. Add meg, hány csapat maradt ki a 3. fordulóból. Ehhez a DARAB és DARAB2 függvény lesz a segítségedre. Az oszlopban számok és – jelek találhatóak. Számold meg az összes csapatot függvény segítségével, majd vond ki azokat, akik részt vettek (számot tartalmaz a cella).

Cellán belül így fest: =DARAB2(E6:E13)-DARAB(E6:E13)

Excel alapfüggvények feladat – DARAB, DARAB2 függvények

Az eredmény: 2

Excel alapfüggvények feladat – DARABTELI, ÁTLAG függvények

4. A D17 cellába számold meg, hogy hány átlag feletti összpontszámmal rendelkező csapat van. Ismét a DARADTELI függvény kell, aminek a kritérium argumentumába az ÁTLAG függvényt kell beillesztened.

A Tartomány az összpontszám oszlopa. A kritérium pedig, hogy nagyobb legyen, mint az átlag összpontszám (>ÁTLAG(F6:F13).

Az ÁTLAG függvényt egy és (&) jellel kell hozzáfűzni a relációs jelhez. Amit idézőjelek közé kell tenni, mint a szöveges adatot.

Cellába írva: =DARABTELI(F6:F13;”>”&ÁTLAG(F6:F13))

Excel alapfüggvények feladat – DARABTELI, ÁTLAG függvények

Az eredmény: 4

Excel alapfüggvények feladat – HA függvény

5. Jöhet az Eredmény oszlop kitöltése. Akkor eredményes egy csapat, HA az összpontszáma nem nulla.

HA függvénnyel egyszerűen megvalósítható: =HA(F6=0;”érvénytelen”;”érvényes”)

Excel alapfüggvények feladat – HA függvény

Az eredmény érvényes lett. Az összes csapat eredményessége a másolás után látható. Másold le az összes csapatra a függvényt.

Excel alapfüggvények feladat – MAX függvény

6. Az utolsó feladat, hogy add meg a H oszlopban, hogy melyik csapat hány ponttal maradt le az első csapattól. A legtöbb pontból ki kell vonni minden csapat pontszámát egyesével. A legtöbb pontot MAX függvénnyel határozd meg.

Arra figyelj, hogy mivel másolni kell a képletet, a dollárjeleket ne felejtsd el kitenni. Erről bővebben, a Hogyan használjam a dollárjeleket a képletekben? bejegyzésünkben olvashatsz.

A H6 cellában : =MAX($F$6:$F$13)-F6

Excel alapfüggvények feladat – MAX függvény

Az eredmény: 20

Most másold végig minden csapatra!

A feladatok végeredménye:

A feladatok végeredménye:

A megoldás a második munkalapon található.

Ha tetszett, kérlek, oszd meg másokkal is! Bátran böngéssz a többi témánk között!