A DARABTELI függvény (angolul COUNTIF függvény) megszámolja azokat a cellákat a megadott tartományban, amelyek eleget tesznek egy adott feltételnek. Nézzük meg a különböző használati lehetőségeket.

Argumentumai: DARABTELI(tartomány; kritérium)

DARABTELI függvény szám kritériummal

Első részben vegyük sorra azokat az eseteket, amikor számok vannak a cellákban, ezekre határozunk meg feltételeket.

Online Excel tanfolyam

DARABTELI függvény konkrét szám kritériummal

Az adott számtartományt fogom végig vizsgálni. Az első példában azt keresem, hogy hány olyan cella van, amelynek értéke 35. A függvény:

DARABTELI(A6:A15;35), az eredmény 2.

DARABTELI függvény

DARABTELI függvény – konkrét szám kritérium cellahivatkozással

Ugyanez a feladat cellahivatkozással így néz ki:

DARABTELI függvény

DARABTELI függvény – Intervallum kritérium cellahivatkozással

Nem csak konkrét számokat, hanem intervallumokat is tudok vizsgálni, például azt, hogy hány olyan szám van, amely 20-nál kisebb. Ekkor a cellába beírom a relációjelet is, <20 és ezt hivatkozom be.

COUNTIF függvény

Ugyanennek egy másik lehetséges megoldása, ha csak a 20-at írod a cellába, és a relációjelet a függvénybe. Ez már egy kicsit trükkösebb, mert a szöveges tartalmú részt idézőjelek közé teszem, a cellahivatkozást nem. De hogy lesz akkor ebből egy egység? Úgy, hogy össze kell őket fűzni & jellel.

=DARABTELI(A6:A15;”<“&B5)

DARABTELI függvény példa

DARABTELI függvény – Intervallum kritérium a függvényben

Ha ugyanezt nem egy külső cellában tenném meg, hanem beírom a függvénybe, ott viszont fontos, hogy idézőjelek között kell megadnom, mert nem számérték.

=DARABTELI(A6:A15;”<20″)

DARABTELI szám kritérium

Ha azt szeretnéd vizsgálni, hogy hány olyan cella van, ami nem egyenlő egy adott értékkel, akkor használd a <> jeleket ilyen formában.

DARABTELI függvény VAGY kritériummal

Ha több kritériumod van és ezek között VAGY kapcsolat van (vagy az egyik, vagy a másik), akkor adj össze két DARABTELI függvényt.

=DARABTELI(A6:A15;B4)+DARABTELI(A6:A15;B5)

Az egyik DARABTELI függvényben megszámolom a 33 tartalmú cellákat, a másikban a 35 tartalmúakat.

DARABTELI Vagy kritérium

Átlag alatti értékek megszámolása DARABTELI függvénnyel

A függvényeket egymásba is ágyazhatjuk, a DARABTELI függvénnyel adjuk meg, hogy hány olyan cella van, ami átlag alatti értéket mutat.

=DARABTELI(A6:A15;”<“&ÁTLAG(A6:A15))

Darabteli függvény excel

Ha kíváncsi vagy az átlagra, a szerkesztőlécen jelöld ki az ÁTLAG(A6:A15) részt, majd nyomd meg az F9 billentyűt, ki fogja írni az eredményt. Innen viszont úgy lépj ki, hogy Esc billentyűt megnyomod, nehogy felülírd a függvényt ezzel az eredménnyel.

DARABTELI függvény részeredmény

DARABTELI függvény szöveges kritériummal

Természetesen használhatjuk szöveges kritériumok esetén, ekkor mások a szabályok.

DARABTELI függvény szöveges feltétellel

A lenti példában arra vagyok kíváncsi, hány olyan cella van, ami Péterrel egyenlő. A kis- és nagybetűk nem számítanak, de a feltételt, mivel szöveges, idézőjelek közé kell tenni.

cellák megszámolása Excel

Az eredmény 1, mert csak egy cella van, amelynek a tartalma Péter. Ha azokat a cellákat szeretnéd megszámolni, amelyik tartalmazza bárhol a Pétert (cella elején, közepén, végén), akkor máshogy kell beírni, ezt mutatom meg a DARABTELI karakterhelyettesítőkkel résznél. Előbb nézzük ugyanezt cellahivatkozással.

DARABTELI függvény cellahivatkozással

A Péter feltételt behivatkozhatom cellából is, az eredmény ugyanaz.

=DARABTELI(A6:A13;B5)

DARABTELI Excel

DARABTELI függvény karakterhelyettesítőkkel

Számoljuk meg azokat a cellákat, amelyek többek között tartalmazzák azt is, hogy Péter (emellett más karakterek is vannak a cellában).

Két karakterhelyettesítőnk a csillag ( * ) és a kérdőjel (?). A csillag akármennyi karaktert helyettesít ott, ahova elhelyezed.

Példák:

*Péter azokat a cellákat jelenti, ahol a Pétert megelőzheti bármi, de utána nincs semmilyen karakter.

DARABTELI tartalmaz

Péter* azokat a cellákat takarja, ahol Péter névvel kezdődik a cella, de a Péter mögött bármennyi karakter állhat.

DARABTELI excel

*Péter* pedig azok a cellák, ahol a Péter előtt és után is lehetnek karakterek.

COUNTIF függvény

A kérdőjel viszont úgy működik, hogy egy kérdőjel egy karaktert helyettesít. Ha azokat a cellákat szeretném figyelembe venni, ahol Péter előtt négytagú vezetéknév áll (plusz ugye a szóköz), akkor így kell megadnom: ?????Péter. Ekkor csak azokat a cellákat számolja, ahol a Pétert pontosan 5 karakter előzi meg a cellában és utána nincs semmi.

DARABTELI helyettesítő

Ezeket persze beírhatod a függvényen belül is, de emlékezz, hogy ott idézőjelek közé kell tenni. pl: ”*Péter*”

DARABTELI függvény – Csak szöveges cellák megszámolása

Érdekesség, hogy meg tudom számolni azokat a cellákat is, amelyek szöveget tartalmaznak. Ehez a kritériumot így kell megadni a függvényben: ”*” . Vagy írd be külön cellába és csak hivatkozd be.

nem üres cellák megszámolása

DARABTELI függvény – IGAZ/HAMIS értékek megszámolása

Függvény, vagy képlet eredményekét kapsz legtöbbször IGAZ és HAMIS értékeket (boolean adattípusok). Meg tudjuk számolni ezeket is a DARABTELI függvénnyel.

IGAZ értékek megszámolása

Bár ez is szöveges adatnak tűnik, nem az, így nem szükséges idézőjelekbe tenned a függvényben.

DARABTELI függvény – Hiba megszámolása

A függvények, képletek által adott hibákat is meg tudod számolni, akár kifejezetten egy-egy hibát véve, pl: #NÉV? hiba, vagy azt is, hogy összesen hány hibás cella van (függetlenül a hibától).
#NÉV? hibák megszámolása: =DARABTELI(A6:A13;”#NÉV?”), zárójelekben kell szerepeltetni.

Hibás cellák megszámolása darabteli

DARABTELI függvény – Összes hibás cella megszámolása

Habár ez nem DARABTELI függvény, mivel ide illő, megmutatok erre is egy megoldást.

Összes hibás cella megszámolása

A HIBÁS függvény (ISERROR) megvizsgálja az adott cellát, ha hibát tartalmaz, akkor az eredménye IGAZ, ha nem hibás, akkor HAMIS. Ezeket átalakítom a HA függvénnyel (IF) 0 és 1 értékekre, majd a SZUM függvénnyel összeadom.

DARABTELI függvény – Szöveges kritérium VAGY kapcsolattal

Ugyanúgy, ahogy számoknál, úgy szöveges értékeknél is alkalmazhatunk VAGY kritériumot: számolja össze azokat a cellákat, amelyek vagy az egyik, vagy a másik feltételnek eleget tesznek. A példában a kék és zöld cellákat számoljuk meg.

cellák megszámolása excelben

DARABÜRES függvény – Üres cellák megszámolása

Megint csak nem DARABTELI, de ugyanabba a „családba” tartozik a DARABÜRES függvény (COUNTBLANK), amely nevéből adódóan az üres cellákat fogja megszámolni. Kritérium nem is szükséges.

DARABÜRES függvény

DARAB2 függvény – Nem üres cellák megszámolása

Szintén egy hasznos függvény, amely a nem üres cellákat számolja meg, neve DARAB2 (angolul COUNTA függvény).

DARAB2 függvény

DARABTELI két feltétellel – DARABHATÖBB függvény

Nem maradhat ki az sem, amikor egynél több feltétel alapján szeretném megszámolni a cellákat, erre is van külön függvényünk, ami a DARABHATÖBB függvény (angolul COUNTIFS függvény).

Argumentumai: DARABHATÖBB(kritériumtartomány1; kritérium1; kritériumtartomány2; kritérium2…)

DARABHATÖBB függvény

A példában megszámoljuk azokat a cellákat, ahol a szín kék és a kész oszlopban „ok” szerepel.

Erre a függvényre is igazak a fenti példákban látottak (idézőjelek, cellahivatkozások használata stb.)

Bízom benne, hogy átfogó képet kaptál a különböző cellák megszámolásához! Ha tetszett, kérlek oszd meg másokkal is.

DARABTELI függvény gyakorlófeladat

További példákat találsz letölthető gyakorlófájllal az Excelneked.hu oldalunkon a DARABTELI, DARABHATÖBB függvények bejegyzésünkben.